마인크래프트 플러그인 제작 2 – 마인크래프트용 라이브러리 연결

Eclipse 에 마인크래프트 라이브러리 연결

Eclipse Java 를 실행합니다.

[File]=> [New] => [Java Project]를 선택합니다.

좌측에 빨간색으로 표시한 버턴 또는 [Window] => [Show View] => [Package Explorer]를 클릭하여 Package Explorer 를 열수 있습니다.

주로 좌측의 Package Explorer 창을 사용하여 작업이 진행됩니다.
(혹시 중간에 Package Explorer 창이 보이지 않는다면 위 방법으로 보이게 할수 있습니다.)

패키지 추가

먼저 패키지를 추가해줘야 합니다.
[src] => [New] => [Package]를 클릭합니다.

Source folder와 Name은 그대로 두고 Finish로 완료합니다.
(이름 변경은 사용방법이 익숙해 진 후에 하시면 됩니다.^^)

클래스 추가

Name을 입력해 줍니다.
(지금은 Name도 Package 과 동일하게 해줍니다.)

이제 코드를 입력할 수 있는 창이 나타납니다.

플러그인용 프로그램을 제작하기 위해 플러그인 기본 구조를 가져와야 합니다.
뒤에 “extends JavaPlugin” 를 추가해줍니다.

하지만 빨간줄로 에러표시해 줍니다.
JavaPlugin 가 찾지 못해서 에러를 표시한 것입니다.

JavaPlugin 의 위치(경로)를 알려 주면 됩니다.

[Build Path] => [ Configure Build Path]를 클릭합니다.

아래와 같이 에러 표시에 마우스 커서를 올려 놓으면 관련 에러를 표시하며 해결방법도 제시해줍니다.
“Import JavaPlugin………….” 을 선택하여 JavaPlugin을 Import 해줍니다.

이제 JavaPlugin 까지 연결하였습니다.

댓글 남기기

이메일은 공개되지 않습니다.